[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Linphone-users]Enabling ALSA drivers?

From: Simon Morlat
Subject: Re: [Linphone-users]Enabling ALSA drivers?
Date: 12 Jun 2003 21:36:54 +0200


I've read your previous email about the "fucking remote sipphone".
Unfortunately I'm not able to explain you exactly what's going wrong.
What I know is that I remember to have fixed such a bug some time ago in
my development version (upcoming 0.12.0).
So I recommend that you try it. You can download it at
Concerning your question about alsa support: it was not finished and so
disabled in linphone-0.11.0. Fortunately it is now fully functionnal in
linphone-0.12.0, so you will be able to play with it too.
In order to use it in console mode, you have to set the good
dev_id=[card_number] in your .linphonec. Linphone scans first for oss
devices (/dev/dspX) then alsa devices through asoundlib.
If you have only one card, the dev_id for the alsa card is then 1,(0 for
oss). If you use the gnome interface, then it appears clearly in a combo
Concerning your 4 minutes delay; I never heard this before. I think it
is related to the RTP stream. In order to do that, the sender has to
send its first RTP packet with timestamp t, then all the other ones with
(t+(8000*60*4)+n*160) where n is the packet index.
The receiver then will have to wait 4 minutes between the first packet
and the following ones.
Please verify that this problem was not momentary. As oRTP already runs
within deployed systems, I would think that the problem was more in the
Cisco Phone.
I'm using Debian Sid with the intel8x0 alsa driver, and I get very good
latency. The intel8x0 is a good driver.
I'm interested in any feedback about linphone-0.12.0pre1.


Le ven 06/06/2003 à 19:37, Matthew Lawson a écrit :
> Hello,
> I am attempting to use Linphone to call a Cisco 7960 phone over 
> Asterisk.  I am using Debian Linux 3.0r1 (Woody?).  I am using the ALSA 
> intel8x0 sound driver.
> What happens, audio from the computer to the Cisco is OK, but audio from 
> the Cisco from the computer doesn't arrive until 4 MINUTES later. 
>  That's right, minutes not seconds.  I'm using Linphone 0.11.0.  I'm 
> also using the command-line only version (linphonec).  The user's manual 
> says to select "use ALSA" from the Gnome GUI, which I obviously can't 
> do, and I can't figure out if there's a flag in the .linphonec 
> configuration file that should be set for this.
> I tried using the --enable-alsa switch with configure, and the "-DALSA" 
> flag seems to be set, but when I run the program, it appears to still be 
> using the OSS routines.  I put diagnostic messages in the 
> "alsa_read/write" and "oss read/write" routines and it's still using the 
> oss routines.  Is this right?
> If not, how do I get it to use ALSA, and is this likely the problem?
> Thanks.
> - Matt
> _______________________________________________
> Linphone-users mailing list
> address@hidden
Simon Morlat <address@hidden>

reply via email to

[Prev in Thread] Current Thread [Next in Thread]