[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Linphone-users] Windows 8 (no audio; no rtp packets received)

From: Ghislain Mary
Subject: Re: [Linphone-users] Windows 8 (no audio; no rtp packets received)
Date: Wed, 19 Dec 2012 15:02:47 +0100


I think you are having some trouble with Windows 8 here, not with Linphone. Everything is correct in the logs.
What can be seen is that both sides send their RTP packet stream correctly but receive nothing:

bandwidth usage: audio=[d=0.0,u=36.6] video=[d=0.0,u=0.0] kbit/sec
Audio session's RTP statistics :
  number of rtp packet sent=547
  number of rtp bytes sent=36619 bytes
  number of rtp packet received=0
  number of rtp bytes received=0 bytes
  number of incoming rtp bytes successfully delivered to the application=0
  number of rtp packet lost=0
  number of rtp packets received too late=0
  number of bad formatted rtp packets=0
  number of packet discarded because of queue overflow=0

I suggest that you check your firewall configuration. Hint: the port used for audio RTP stream is UDP 7078.
Or the problem may come from the configuration of your NAT. Unwanted port forwarding maybe?


On 19 December 2012 08:35, <address@hidden> wrote:

My friend just got a Windows 8 laptop and we're trying to use linphone with each
other, but neither of us seem to be getting any audio from each other. With a
closer look at the logs, I've determined that we don't seem to be receiving each
other's RTP packets at all.

This is very strange because when my friend had the previous laptop with Windows
7, linphone worked just fine. We tried to mess with the preferences in a variety
of ways, but we still don't seem to get anything from each other.

I've attached logs from when we called each other. I've anonymized the logins so
that my friend is charmander with public IP address, and I am squirtle
with public IP address In the logs, we're both running linphone version
3.5.2 with SIP (UDP) (port 5060), no media encryption, no video, and behind NAT
(using STUN to resolve): Charmander (my friend) is running on
Windows 8 and squritle is running on Linux 3.6.

We've both confirmed that we're able to interact with the echo test from
sip:address@hidden, and we're actually able to communicate with each other when
charmander uses a different voip phone (yate) while squirtle uses linphone.

I'd appreciate it if anyone could help us. Thanks.

Linphone-users mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]