[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: MIT Scheme 11.1 fails to build because of Werror

From: Taylor R Campbell
Subject: Re: MIT Scheme 11.1 fails to build because of Werror
Date: Wed, 3 Feb 2021 14:48:09 +0000

> Date: Wed, 3 Feb 2021 12:33:08 +0100
> From: Schnoering Gabriel <>
> I have ncurses and the related headers installed.
> I tried the procedure again with an older gcc (7) for the same result 
> (Werror complaints).

Can you share your src/microcode/config.log?

> scmutils doesn't run on the new version though.
> Bad compiled-code version in FASL File: mit-scheme-x86-64-11.1/
> File has: compiled-code interface 3; architecture 14.
> Expected: compiled-code interface 4; architecture 14.
> Microcode Error: No error handlers.
> Error code 0x3a (fasload-compiled-mismatch)
> I will stick to the older version for now.

The from a scmutils built on 10.x won't work with 11.x;
you'll need a built on 11.x.  (Sorry about that!  I made
some bad design decisions in the amd64 compiler over a decade ago, and
changed them in 11.x to make essentially all code about 20% faster but
the compiled code is not compatible.)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]