[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PULL 07/23] hw/sd/pl181: Rename pl181_send_command() as pl181_do_comman
From: |
Philippe Mathieu-Daudé |
Subject: |
[PULL 07/23] hw/sd/pl181: Rename pl181_send_command() as pl181_do_command() |
Date: |
Fri, 21 Aug 2020 19:29:00 +0200 |
pl181_send_command() do a bus transaction (send or receive),
rename it as pl181_do_command().
Signed-off-by: Philippe Mathieu-Daudé <f4bug@amsat.org>
Reviewed-by: Alistair Francis <alistair.francis@wdc.com>
Acked-by: Peter Maydell <peter.maydell@linaro.org>
Message-Id: <20200705204630.4133-3-f4bug@amsat.org>
---
hw/sd/pl181.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/hw/sd/pl181.c b/hw/sd/pl181.c
index 649386ec3d1..3fc2cdd71a1 100644
--- a/hw/sd/pl181.c
+++ b/hw/sd/pl181.c
@@ -173,7 +173,7 @@ static uint32_t pl181_fifo_pop(PL181State *s)
return value;
}
-static void pl181_send_command(PL181State *s)
+static void pl181_do_command(PL181State *s)
{
SDRequest request;
uint8_t response[16];
@@ -402,7 +402,7 @@ static void pl181_write(void *opaque, hwaddr offset,
qemu_log_mask(LOG_UNIMP,
"pl181: Pending commands not implemented\n");
} else {
- pl181_send_command(s);
+ pl181_do_command(s);
pl181_fifo_run(s);
}
/* The command has completed one way or the other. */
--
2.26.2
- [PULL 00/23] SD/MMC patches for 2020-08-21, Philippe Mathieu-Daudé, 2020/08/21
- [PULL 01/23] hw/sd/pxa2xx_mmci: Do not create SD card within the SD host controller, Philippe Mathieu-Daudé, 2020/08/21
- [PULL 02/23] hw/sd/pxa2xx_mmci: Trivial simplification, Philippe Mathieu-Daudé, 2020/08/21
- [PULL 04/23] hw/sd/milkymist: Create the SDBus at init(), Philippe Mathieu-Daudé, 2020/08/21
- [PULL 03/23] hw/lm32/milkymist: Un-inline milkymist_memcard_create(), Philippe Mathieu-Daudé, 2020/08/21
- [PULL 05/23] hw/sd/milkymist: Do not create SD card within the SD host controller, Philippe Mathieu-Daudé, 2020/08/21
- [PULL 06/23] hw/sd/pl181: Replace fprintf(stderr, "*\n") with error_report(), Philippe Mathieu-Daudé, 2020/08/21
- [PULL 07/23] hw/sd/pl181: Rename pl181_send_command() as pl181_do_command(),
Philippe Mathieu-Daudé <=
- [PULL 08/23] hw/sd/pl181: Add TODO to use Fifo32 API, Philippe Mathieu-Daudé, 2020/08/21
- [PULL 09/23] hw/sd/pl181: Use named GPIOs, Philippe Mathieu-Daudé, 2020/08/21
- [PULL 10/23] hw/sd/pl181: Expose a SDBus and connect the SDCard to it, Philippe Mathieu-Daudé, 2020/08/21
- [PULL 11/23] hw/sd/pl181: Do not create SD card within the SD host controller, Philippe Mathieu-Daudé, 2020/08/21
- [PULL 12/23] hw/sd/pl181: Replace disabled fprintf()s by trace events, Philippe Mathieu-Daudé, 2020/08/21
- [PULL 14/23] hw/sd: Move sdcard legacy API to 'hw/sd/sdcard_legacy.h', Philippe Mathieu-Daudé, 2020/08/21
- [PULL 13/23] hw/sd/sdcard: Make sd_data_ready() static, Philippe Mathieu-Daudé, 2020/08/21
- [PULL 15/23] hw/sd: Rename read/write_data() as read/write_byte(), Philippe Mathieu-Daudé, 2020/08/21
- [PULL 16/23] hw/sd: Rename sdbus_write_data() as sdbus_write_byte(), Philippe Mathieu-Daudé, 2020/08/21
- [PULL 18/23] hw/sd: Add sdbus_write_data() to write multiples bytes on the data line, Philippe Mathieu-Daudé, 2020/08/21