qemu-commits
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-commits] [qemu/qemu] ae163b: hw/i2c/Kconfig: Add an entry for the


From: Peter Maydell
Subject: [Qemu-commits] [qemu/qemu] ae163b: hw/i2c/Kconfig: Add an entry for the SMBus
Date: Mon, 20 Jul 2020 03:15:30 -0700

  Branch: refs/heads/master
  Home:   https://github.com/qemu/qemu
  Commit: ae163b8d9588f02de6a4b6dba310307ba485d4a9
      
https://github.com/qemu/qemu/commit/ae163b8d9588f02de6a4b6dba310307ba485d4a9
  Author: Philippe Mathieu-Daudé <philmd@redhat.com>
  Date:   2020-07-16 (Thu, 16 Jul 2020)

  Changed paths:
    M hw/i2c/Kconfig
    M hw/i2c/Makefile.objs

  Log Message:
  -----------
  hw/i2c/Kconfig: Add an entry for the SMBus

The System Management Bus is more or less a derivative of the I2C
bus, thus the Kconfig entry depends of I2C.
Not all boards providing an I2C bus support SMBus.
Use two different Kconfig entries to be able to select I2C without
selecting SMBus.

Signed-off-by: Philippe Mathieu-Daudé <philmd@redhat.com>
Message-Id: <20191231183216.6781-6-philmd@redhat.com>
Signed-off-by: Corey Minyard <cminyard@mvista.com>


  Commit: 7a204cbdc280fd9ab6c8d34a01f112ea5e809f70
      
https://github.com/qemu/qemu/commit/7a204cbdc280fd9ab6c8d34a01f112ea5e809f70
  Author: Philippe Mathieu-Daudé <f4bug@amsat.org>
  Date:   2020-07-16 (Thu, 16 Jul 2020)

  Changed paths:
    M hw/arm/aspeed.c
    M hw/i2c/aspeed_i2c.c
    M include/hw/i2c/aspeed_i2c.h

  Log Message:
  -----------
  hw/i2c/aspeed_i2c: Simplify aspeed_i2c_get_bus()

All the callers of aspeed_i2c_get_bus() have a AspeedI2CState and
cast it to a DeviceState with DEVICE(), then aspeed_i2c_get_bus()
cast the DeviceState to an AspeedI2CState with ASPEED_I2C()...

Simplify aspeed_i2c_get_bus() callers by using AspeedI2CState
argument.

Reviewed-by: Markus Armbruster <armbru@redhat.com>
Reviewed-by: Andrew Jeffery <andrew@aj.id.au>
Reviewed-by: Cédric Le Goater <clg@kaod.org>
Signed-off-by: Philippe Mathieu-Daudé <f4bug@amsat.org>
Message-Id: <20200705224154.16917-2-f4bug@amsat.org>
Signed-off-by: Corey Minyard <cminyard@mvista.com>


  Commit: db437ca6dfc8db3d91ee75babc4b1fee8c95e9ab
      
https://github.com/qemu/qemu/commit/db437ca6dfc8db3d91ee75babc4b1fee8c95e9ab
  Author: Philippe Mathieu-Daudé <f4bug@amsat.org>
  Date:   2020-07-16 (Thu, 16 Jul 2020)

  Changed paths:
    M hw/arm/aspeed.c
    M hw/i2c/core.c
    M include/hw/i2c/i2c.h

  Log Message:
  -----------
  hw/i2c: Rename i2c_try_create_slave() as i2c_slave_new()

We use "new" names for functions that allocate and initialize
device objects: pci_new(), isa_new(), usb_new().
Let's call this one i2c_slave_new(). Since we have to update
all the callers, also let it return a I2CSlave object.

Suggested-by: Markus Armbruster <armbru@redhat.com>
Reviewed-by: Markus Armbruster <armbru@redhat.com>
Signed-off-by: Philippe Mathieu-Daudé <f4bug@amsat.org>
Message-Id: <20200705224154.16917-3-f4bug@amsat.org>
Signed-off-by: Corey Minyard <cminyard@mvista.com>


  Commit: 2616f57231c8e065df77de894a8f018cd1842c95
      
https://github.com/qemu/qemu/commit/2616f57231c8e065df77de894a8f018cd1842c95
  Author: Philippe Mathieu-Daudé <f4bug@amsat.org>
  Date:   2020-07-16 (Thu, 16 Jul 2020)

  Changed paths:
    M hw/arm/aspeed.c
    M hw/i2c/core.c
    M include/hw/i2c/i2c.h

  Log Message:
  -----------
  hw/i2c: Rename i2c_realize_and_unref() as i2c_slave_realize_and_unref()

The other i2c functions are called i2c_slave_FOO(). Rename as
i2c_slave_realize_and_unref() to be consistent.

Suggested-by: Markus Armbruster <armbru@redhat.com>
Reviewed-by: Corey Minyard <cminyard@mvista.com>
Signed-off-by: Philippe Mathieu-Daudé <f4bug@amsat.org>
Message-Id: <20200705224154.16917-4-f4bug@amsat.org>
Signed-off-by: Corey Minyard <cminyard@mvista.com>


  Commit: 1373b15bb55e46b067f84f70c60d3d03af62fd62
      
https://github.com/qemu/qemu/commit/1373b15bb55e46b067f84f70c60d3d03af62fd62
  Author: Philippe Mathieu-Daudé <f4bug@amsat.org>
  Date:   2020-07-16 (Thu, 16 Jul 2020)

  Changed paths:
    M hw/arm/aspeed.c
    M hw/arm/musicpal.c
    M hw/arm/nseries.c
    M hw/arm/pxa2xx.c
    M hw/arm/realview.c
    M hw/arm/spitz.c
    M hw/arm/stellaris.c
    M hw/arm/tosa.c
    M hw/arm/versatilepb.c
    M hw/arm/vexpress.c
    M hw/arm/z2.c
    M hw/display/sii9022.c
    M hw/i2c/core.c
    M hw/ppc/e500.c
    M hw/ppc/sam460ex.c
    M include/hw/i2c/i2c.h

  Log Message:
  -----------
  hw/i2c: Rename i2c_create_slave() as i2c_slave_create_simple()

We use "create_simple" names for functions that allocate, initialize,
configure and realize device objects: pci_create_simple(),
isa_create_simple(), usb_create_simple(). For consistency, rename
i2c_create_slave() as i2c_slave_create_simple(). Since we have
to update all the callers, also let it return a I2CSlave object.

Suggested-by: Markus Armbruster <armbru@redhat.com>
Reviewed-by: Corey Minyard <cminyard@mvista.com>
Reviewed-by: Markus Armbruster <armbru@redhat.com>
Signed-off-by: Philippe Mathieu-Daudé <f4bug@amsat.org>
Message-Id: <20200705224154.16917-5-f4bug@amsat.org>
Signed-off-by: Corey Minyard <cminyard@mvista.com>


  Commit: 73d5f22ecbb76dfc785876779d47787084ff0f42
      
https://github.com/qemu/qemu/commit/73d5f22ecbb76dfc785876779d47787084ff0f42
  Author: Philippe Mathieu-Daudé <f4bug@amsat.org>
  Date:   2020-07-16 (Thu, 16 Jul 2020)

  Changed paths:
    M include/hw/i2c/i2c.h

  Log Message:
  -----------
  hw/i2c: Document the I2C qdev helpers

In commit d88c42ff2c we added new prototype but neglected to
add their documentation. Fix that.

Reported-by: Peter Maydell <peter.maydell@linaro.org>
Reviewed-by: Corey Minyard <cminyard@mvista.com>
Reviewed-by: Peter Maydell <peter.maydell@linaro.org>
Signed-off-by: Philippe Mathieu-Daudé <f4bug@amsat.org>
Message-Id: <20200705224154.16917-6-f4bug@amsat.org>
Signed-off-by: Corey Minyard <cminyard@mvista.com>


  Commit: d69cda7ed722e445d03e1ace6563bab3a76e023e
      
https://github.com/qemu/qemu/commit/d69cda7ed722e445d03e1ace6563bab3a76e023e
  Author: Peter Maydell <peter.maydell@linaro.org>
  Date:   2020-07-20 (Mon, 20 Jul 2020)

  Changed paths:
    M Makefile

  Log Message:
  -----------
  Makefile: Remove config-devices.mak on "make clean"

The config-devices.mak files are generated by "make", and so they
should be deleted by "make clean".

(This is different from config-host.mak and config-all-disas.mak,
which are created by "configure" and so only deleted by
"make distclean".)

If we don't delete these files on "make clean", then the build
tree is left in a state where it has the config-devices.mak
file but not the config-devices.mak.d file, and make will not
realize that it needs to rebuild config-devices.mak if, for
instance, hw/sd/Kconfig changes.

NB: config-all-devices.mak is also generated by "make", but we
already remove it on "make clean".

Suggested-by: Paolo Bonzini <pbonzini@redhat.com>
Signed-off-by: Peter Maydell <peter.maydell@linaro.org>
Reviewed-by: Philippe Mathieu-Daudé <philmd@redhat.com>
Message-id: 20200717152508.10272-1-peter.maydell@linaro.org


  Commit: 873ec69aeb12e24eec7fb317fd0cd8494e8489dd
      
https://github.com/qemu/qemu/commit/873ec69aeb12e24eec7fb317fd0cd8494e8489dd
  Author: Peter Maydell <peter.maydell@linaro.org>
  Date:   2020-07-20 (Mon, 20 Jul 2020)

  Changed paths:
    M hw/arm/aspeed.c
    M hw/arm/musicpal.c
    M hw/arm/nseries.c
    M hw/arm/pxa2xx.c
    M hw/arm/realview.c
    M hw/arm/spitz.c
    M hw/arm/stellaris.c
    M hw/arm/tosa.c
    M hw/arm/versatilepb.c
    M hw/arm/vexpress.c
    M hw/arm/z2.c
    M hw/display/sii9022.c
    M hw/i2c/Kconfig
    M hw/i2c/Makefile.objs
    M hw/i2c/aspeed_i2c.c
    M hw/i2c/core.c
    M hw/ppc/e500.c
    M hw/ppc/sam460ex.c
    M include/hw/i2c/aspeed_i2c.h
    M include/hw/i2c/i2c.h

  Log Message:
  -----------
  Merge remote-tracking branch 'remotes/cminyard/tags/for-qemu-i2c-5' into 
staging

Minor changes to:

Add an SMBus config entry

Cleanup/simplify/document some I2C interfaces

# gpg: Signature made Thu 16 Jul 2020 18:46:55 BST
# gpg:                using RSA key FD0D5CE67CE0F59A6688268661F38C90919BFF81
# gpg: Good signature from "Corey Minyard <cminyard@mvista.com>" [unknown]
# gpg:                 aka "Corey Minyard <minyard@acm.org>" [unknown]
# gpg:                 aka "Corey Minyard <corey@minyard.net>" [unknown]
# gpg:                 aka "Corey Minyard <minyard@mvista.com>" [unknown]
# gpg: WARNING: This key is not certified with a trusted signature!
# gpg:          There is no indication that the signature belongs to the owner.
# Primary key fingerprint: FD0D 5CE6 7CE0 F59A 6688  2686 61F3 8C90 919B FF81

* remotes/cminyard/tags/for-qemu-i2c-5:
  hw/i2c: Document the I2C qdev helpers
  hw/i2c: Rename i2c_create_slave() as i2c_slave_create_simple()
  hw/i2c: Rename i2c_realize_and_unref() as i2c_slave_realize_and_unref()
  hw/i2c: Rename i2c_try_create_slave() as i2c_slave_new()
  hw/i2c/aspeed_i2c: Simplify aspeed_i2c_get_bus()
  hw/i2c/Kconfig: Add an entry for the SMBus

Signed-off-by: Peter Maydell <peter.maydell@linaro.org>


Compare: https://github.com/qemu/qemu/compare/9fc87111005e...873ec69aeb12



reply via email to

[Prev in Thread] Current Thread [Next in Thread]