[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH v5 03/11] mac_oldworld: Drop a variable, use get_system_memor
From: |
Mark Cave-Ayland |
Subject: |
Re: [PATCH v5 03/11] mac_oldworld: Drop a variable, use get_system_memory() directly |
Date: |
Fri, 26 Jun 2020 13:42:51 +0100 |
User-agent: |
Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.9.0 |
On 16/06/2020 14:47, BALATON Zoltan wrote:
> Half of the occurances already use get_system_memory() directly
> instead of sysmem variable, convert the two other uses to
> get_system_memory() tii which seems to be more common and drop the
> variable.
>
> Signed-off-by: BALATON Zoltan <balaton@eik.bme.hu>
> ---
> hw/ppc/mac_oldworld.c | 5 ++---
> 1 file changed, 2 insertions(+), 3 deletions(-)
>
> diff --git a/hw/ppc/mac_oldworld.c b/hw/ppc/mac_oldworld.c
> index baf3da6f90..d1c4244b1e 100644
> --- a/hw/ppc/mac_oldworld.c
> +++ b/hw/ppc/mac_oldworld.c
> @@ -87,7 +87,6 @@ static void ppc_heathrow_init(MachineState *machine)
> const char *kernel_cmdline = machine->kernel_cmdline;
> const char *initrd_filename = machine->initrd_filename;
> const char *boot_device = machine->boot_order;
> - MemoryRegion *sysmem = get_system_memory();
> PowerPCCPU *cpu = NULL;
> CPUPPCState *env = NULL;
> char *filename;
> @@ -128,12 +127,12 @@ static void ppc_heathrow_init(MachineState *machine)
> exit(1);
> }
>
> - memory_region_add_subregion(sysmem, 0, machine->ram);
> + memory_region_add_subregion(get_system_memory(), 0, machine->ram);
>
> /* allocate and load firmware ROM */
> memory_region_init_rom(bios, NULL, "ppc_heathrow.bios", PROM_SIZE,
> &error_fatal);
> - memory_region_add_subregion(sysmem, PROM_BASE, bios);
> + memory_region_add_subregion(get_system_memory(), PROM_BASE, bios);
>
> if (!bios_name) {
> bios_name = PROM_FILENAME;
Reviewed-by: Mark Cave-Ayland <mark.cave-ayland@ilande.co.uk>
ATB,
Mark.
- Re: [PATCH v5 02/11] mac_newworld: Allow loading binary ROM image, (continued)
- [PATCH v5 04/11] mac_oldworld: Drop some variables, BALATON Zoltan, 2020/06/16
- [PATCH v5 07/11] mac_oldworld: Map macio to expected address at reset, BALATON Zoltan, 2020/06/16
- [PATCH v5 06/11] mac_oldworld: Rename ppc_heathrow_reset to ppc_heathrow_cpu_reset, BALATON Zoltan, 2020/06/16
- [PATCH v5 03/11] mac_oldworld: Drop a variable, use get_system_memory() directly, BALATON Zoltan, 2020/06/16
- Re: [PATCH v5 03/11] mac_oldworld: Drop a variable, use get_system_memory() directly,
Mark Cave-Ayland <=
- [PATCH v5 08/11] mac_oldworld: Add machine ID register, BALATON Zoltan, 2020/06/16
- [PATCH v5 05/11] grackle: Set revision in PCI config to match hardware, BALATON Zoltan, 2020/06/16
- [PATCH v5 10/11] WIP macio/cuda: Attempt to add i2c support, BALATON Zoltan, 2020/06/16
- [PATCH v5 09/11] macio: Add dummy screamer register area, BALATON Zoltan, 2020/06/16