[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH v5 05/11] grackle: Set revision in PCI config to match hardwa
From: |
Mark Cave-Ayland |
Subject: |
Re: [PATCH v5 05/11] grackle: Set revision in PCI config to match hardware |
Date: |
Fri, 26 Jun 2020 13:51:13 +0100 |
User-agent: |
Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.9.0 |
On 16/06/2020 14:47, BALATON Zoltan wrote:
> Signed-off-by: BALATON Zoltan <balaton@eik.bme.hu>
> ---
> hw/pci-host/grackle.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/hw/pci-host/grackle.c b/hw/pci-host/grackle.c
> index 4b3af0c704..48d11f13ab 100644
> --- a/hw/pci-host/grackle.c
> +++ b/hw/pci-host/grackle.c
> @@ -130,7 +130,7 @@ static void grackle_pci_class_init(ObjectClass *klass,
> void *data)
> k->realize = grackle_pci_realize;
> k->vendor_id = PCI_VENDOR_ID_MOTOROLA;
> k->device_id = PCI_DEVICE_ID_MOTOROLA_MPC106;
> - k->revision = 0x00;
> + k->revision = 0x40;
> k->class_id = PCI_CLASS_BRIDGE_HOST;
> /*
> * PCI-facing part of the host bridge, not usable without the
It seems the current value is 0x0, but in one of my dumps I see a value of 0x1,
and
you're suggesting a value of 0x40. Given that there are clearly multiple
revisions of
the hardware, I'd suggest dropping this for now since it's not clear to me yet
exactly which real hardware is being targetted and what side-effect this might
have.
ATB,
Mark.
- Re: [PATCH v5 07/11] mac_oldworld: Map macio to expected address at reset, (continued)
- [PATCH v5 06/11] mac_oldworld: Rename ppc_heathrow_reset to ppc_heathrow_cpu_reset, BALATON Zoltan, 2020/06/16
- [PATCH v5 03/11] mac_oldworld: Drop a variable, use get_system_memory() directly, BALATON Zoltan, 2020/06/16
- [PATCH v5 08/11] mac_oldworld: Add machine ID register, BALATON Zoltan, 2020/06/16
- [PATCH v5 05/11] grackle: Set revision in PCI config to match hardware, BALATON Zoltan, 2020/06/16
- Re: [PATCH v5 05/11] grackle: Set revision in PCI config to match hardware,
Mark Cave-Ayland <=
- [PATCH v5 10/11] WIP macio/cuda: Attempt to add i2c support, BALATON Zoltan, 2020/06/16
- [PATCH v5 09/11] macio: Add dummy screamer register area, BALATON Zoltan, 2020/06/16
- Re: [PATCH v5 09/11] macio: Add dummy screamer register area, Mark Cave-Ayland, 2020/06/26
- Re: [PATCH v5 09/11] macio: Add dummy screamer register area, BALATON Zoltan, 2020/06/28
- Re: [PATCH v5 09/11] macio: Add dummy screamer register area, BALATON Zoltan, 2020/06/28
- Re: [PATCH v5 09/11] macio: Add dummy screamer register area, BALATON Zoltan, 2020/06/28
- Re: [PATCH v5 09/11] macio: Add dummy screamer register area, BALATON Zoltan, 2020/06/28
- Re: [PATCH v5 09/11] macio: Add dummy screamer register area, BALATON Zoltan, 2020/06/28
[PATCH v5 11/11] mac_oldworld: Add SPD data to cover RAM, BALATON Zoltan, 2020/06/16