qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[PATCH 38/63] ccid-card-passthru: Rename PASSTHRU_CCID_CARD to CCID_PASS


From: Eduardo Habkost
Subject: [PATCH 38/63] ccid-card-passthru: Rename PASSTHRU_CCID_CARD to CCID_PASSTHRU
Date: Wed, 2 Sep 2020 18:42:46 -0400

Make the type checking macro name consistent with the TYPE_*
constant.

Signed-off-by: Eduardo Habkost <ehabkost@redhat.com>
---
Cc: Gerd Hoffmann <kraxel@redhat.com>
Cc: qemu-devel@nongnu.org
---
 hw/usb/ccid-card-passthru.c | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/hw/usb/ccid-card-passthru.c b/hw/usb/ccid-card-passthru.c
index e8e9d37e88..d9f569e201 100644
--- a/hw/usb/ccid-card-passthru.c
+++ b/hw/usb/ccid-card-passthru.c
@@ -65,7 +65,7 @@ struct PassthruState {
 };
 
 #define TYPE_CCID_PASSTHRU "ccid-card-passthru"
-DECLARE_INSTANCE_CHECKER(PassthruState, PASSTHRU_CCID_CARD,
+DECLARE_INSTANCE_CHECKER(PassthruState, CCID_PASSTHRU,
                          TYPE_CCID_PASSTHRU)
 
 /*
@@ -332,7 +332,7 @@ static void ccid_card_vscard_event(void *opaque, 
QEMUChrEvent event)
 static void passthru_apdu_from_guest(
     CCIDCardState *base, const uint8_t *apdu, uint32_t len)
 {
-    PassthruState *card = PASSTHRU_CCID_CARD(base);
+    PassthruState *card = CCID_PASSTHRU(base);
 
     if (!qemu_chr_fe_backend_connected(&card->cs)) {
         printf("ccid-passthru: no chardev, discarding apdu length %d\n", len);
@@ -343,7 +343,7 @@ static void passthru_apdu_from_guest(
 
 static const uint8_t *passthru_get_atr(CCIDCardState *base, uint32_t *len)
 {
-    PassthruState *card = PASSTHRU_CCID_CARD(base);
+    PassthruState *card = CCID_PASSTHRU(base);
 
     *len = card->atr_length;
     return card->atr;
@@ -351,7 +351,7 @@ static const uint8_t *passthru_get_atr(CCIDCardState *base, 
uint32_t *len)
 
 static void passthru_realize(CCIDCardState *base, Error **errp)
 {
-    PassthruState *card = PASSTHRU_CCID_CARD(base);
+    PassthruState *card = CCID_PASSTHRU(base);
 
     card->vscard_in_pos = 0;
     card->vscard_in_hdr = 0;
-- 
2.26.2




reply via email to

[Prev in Thread] Current Thread [Next in Thread]