qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH 32/63] ahci: Rename ICH_AHCI to ICH9_AHCI


From: Philippe Mathieu-Daudé
Subject: Re: [PATCH 32/63] ahci: Rename ICH_AHCI to ICH9_AHCI
Date: Thu, 3 Sep 2020 14:57:08 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.11.0

On 9/3/20 12:42 AM, Eduardo Habkost wrote:
> Make the type checking macro name consistent with the TYPE_*
> constant.
> 
> Signed-off-by: Eduardo Habkost <ehabkost@redhat.com>

Reviewed-by: Philippe Mathieu-Daudé <philmd@redhat.com>

> ---
> Cc: John Snow <jsnow@redhat.com>
> Cc: qemu-block@nongnu.org
> Cc: qemu-devel@nongnu.org
> ---
>  include/hw/ide/ahci.h | 2 +-
>  hw/ide/ahci.c         | 4 ++--
>  hw/ide/ich.c          | 8 ++++----
>  3 files changed, 7 insertions(+), 7 deletions(-)
> 
> diff --git a/include/hw/ide/ahci.h b/include/hw/ide/ahci.h
> index 4cf6813d80..da3cddcc65 100644
> --- a/include/hw/ide/ahci.h
> +++ b/include/hw/ide/ahci.h
> @@ -54,7 +54,7 @@ typedef struct AHCIState {
>  typedef struct AHCIPCIState AHCIPCIState;
>  
>  #define TYPE_ICH9_AHCI "ich9-ahci"
> -DECLARE_INSTANCE_CHECKER(AHCIPCIState, ICH_AHCI,
> +DECLARE_INSTANCE_CHECKER(AHCIPCIState, ICH9_AHCI,
>                           TYPE_ICH9_AHCI)
>  
>  int32_t ahci_get_num_ports(PCIDevice *dev);
> diff --git a/hw/ide/ahci.c b/hw/ide/ahci.c
> index b696c6291a..ee1d47ff75 100644
> --- a/hw/ide/ahci.c
> +++ b/hw/ide/ahci.c
> @@ -1819,7 +1819,7 @@ type_init(sysbus_ahci_register_types)
>  
>  int32_t ahci_get_num_ports(PCIDevice *dev)
>  {
> -    AHCIPCIState *d = ICH_AHCI(dev);
> +    AHCIPCIState *d = ICH9_AHCI(dev);
>      AHCIState *ahci = &d->ahci;
>  
>      return ahci->ports;
> @@ -1827,7 +1827,7 @@ int32_t ahci_get_num_ports(PCIDevice *dev)
>  
>  void ahci_ide_create_devs(PCIDevice *dev, DriveInfo **hd)
>  {
> -    AHCIPCIState *d = ICH_AHCI(dev);
> +    AHCIPCIState *d = ICH9_AHCI(dev);
>      AHCIState *ahci = &d->ahci;
>      int i;
>  
> diff --git a/hw/ide/ich.c b/hw/ide/ich.c
> index eff3188fff..51cd2f38b7 100644
> --- a/hw/ide/ich.c
> +++ b/hw/ide/ich.c
> @@ -91,14 +91,14 @@ static const VMStateDescription vmstate_ich9_ahci = {
>  
>  static void pci_ich9_reset(DeviceState *dev)
>  {
> -    AHCIPCIState *d = ICH_AHCI(dev);
> +    AHCIPCIState *d = ICH9_AHCI(dev);
>  
>      ahci_reset(&d->ahci);
>  }
>  
>  static void pci_ich9_ahci_init(Object *obj)
>  {
> -    struct AHCIPCIState *d = ICH_AHCI(obj);
> +    struct AHCIPCIState *d = ICH9_AHCI(obj);
>  
>      ahci_init(&d->ahci, DEVICE(obj));
>  }
> @@ -108,7 +108,7 @@ static void pci_ich9_ahci_realize(PCIDevice *dev, Error 
> **errp)
>      struct AHCIPCIState *d;
>      int sata_cap_offset;
>      uint8_t *sata_cap;
> -    d = ICH_AHCI(dev);
> +    d = ICH9_AHCI(dev);
>      int ret;
>  
>      ahci_realize(&d->ahci, DEVICE(dev), pci_get_address_space(dev), 6);
> @@ -154,7 +154,7 @@ static void pci_ich9_ahci_realize(PCIDevice *dev, Error 
> **errp)
>  static void pci_ich9_uninit(PCIDevice *dev)
>  {
>      struct AHCIPCIState *d;
> -    d = ICH_AHCI(dev);
> +    d = ICH9_AHCI(dev);
>  
>      msi_uninit(dev);
>      ahci_uninit(&d->ahci);
> 




reply via email to

[Prev in Thread] Current Thread [Next in Thread]