qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[PATCH 30/63] versatile: Rename TYPE_VERSATILE_PCI to TYPE_PCI_VPB


From: Eduardo Habkost
Subject: [PATCH 30/63] versatile: Rename TYPE_VERSATILE_PCI to TYPE_PCI_VPB
Date: Wed, 2 Sep 2020 18:42:38 -0400

This will make the type name constant consistent with the name of
the type checking macro.

Signed-off-by: Eduardo Habkost <ehabkost@redhat.com>
---
Cc: Peter Maydell <peter.maydell@linaro.org>
Cc: qemu-arm@nongnu.org
Cc: qemu-devel@nongnu.org
---
 hw/pci-host/versatile.c | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/hw/pci-host/versatile.c b/hw/pci-host/versatile.c
index 7b6a754b8b..9da352c070 100644
--- a/hw/pci-host/versatile.c
+++ b/hw/pci-host/versatile.c
@@ -157,9 +157,9 @@ static const VMStateDescription pci_vpb_vmstate = {
     }
 };
 
-#define TYPE_VERSATILE_PCI "versatile_pci"
+#define TYPE_PCI_VPB "versatile_pci"
 DECLARE_INSTANCE_CHECKER(PCIVPBState, PCI_VPB,
-                         TYPE_VERSATILE_PCI)
+                         TYPE_PCI_VPB)
 
 #define TYPE_PCI_VPB_HOST "versatile_pci_host"
 DECLARE_INSTANCE_CHECKER(PCIDevice, PCI_VPB_HOST,
@@ -514,7 +514,7 @@ static void pci_vpb_class_init(ObjectClass *klass, void 
*data)
 }
 
 static const TypeInfo pci_vpb_info = {
-    .name          = TYPE_VERSATILE_PCI,
+    .name          = TYPE_PCI_VPB,
     .parent        = TYPE_PCI_HOST_BRIDGE,
     .instance_size = sizeof(PCIVPBState),
     .instance_init = pci_vpb_init,
@@ -534,7 +534,7 @@ static void pci_realview_init(Object *obj)
 
 static const TypeInfo pci_realview_info = {
     .name          = "realview_pci",
-    .parent        = TYPE_VERSATILE_PCI,
+    .parent        = TYPE_PCI_VPB,
     .instance_init = pci_realview_init,
 };
 
-- 
2.26.2




reply via email to

[Prev in Thread] Current Thread [Next in Thread]