[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH v3 12/15] acpi/ghes: better name the offset of the hardware error
From: |
Mauro Carvalho Chehab |
Subject: |
[PATCH v3 12/15] acpi/ghes: better name the offset of the hardware error firmware |
Date: |
Tue, 12 Nov 2024 11:14:56 +0100 |
The hardware error firmware is where HEST error structures are
stored. Those can be GHESv2, but they can also be other types.
Better name the location of the hardware error.
No functional changes.
Signed-off-by: Mauro Carvalho Chehab <mchehab+huawei@kernel.org>
Reviewed-by: Jonathan Cameron <Jonathan.Cameron@huawei.com>
Reviewed-by: Igor Mammedov <imammedo@redhat.com>
---
hw/acpi/generic_event_device.c | 4 ++--
hw/acpi/ghes.c | 4 ++--
include/hw/acpi/ghes.h | 2 +-
3 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/hw/acpi/generic_event_device.c b/hw/acpi/generic_event_device.c
index 663d9cb09380..17baf36132a8 100644
--- a/hw/acpi/generic_event_device.c
+++ b/hw/acpi/generic_event_device.c
@@ -364,7 +364,7 @@ static const VMStateDescription vmstate_ghes = {
.version_id = 1,
.minimum_version_id = 1,
.fields = (const VMStateField[]) {
- VMSTATE_UINT64(ghes_addr_le, AcpiGhesState),
+ VMSTATE_UINT64(hw_error_le, AcpiGhesState),
VMSTATE_END_OF_LIST()
},
};
@@ -372,7 +372,7 @@ static const VMStateDescription vmstate_ghes = {
static bool ghes_needed(void *opaque)
{
AcpiGedState *s = opaque;
- return s->ghes_state.ghes_addr_le;
+ return s->ghes_state.hw_error_le;
}
static const VMStateDescription vmstate_ghes_state = {
diff --git a/hw/acpi/ghes.c b/hw/acpi/ghes.c
index f698951630e3..cfe2f061c3eb 100644
--- a/hw/acpi/ghes.c
+++ b/hw/acpi/ghes.c
@@ -365,7 +365,7 @@ void acpi_ghes_add_fw_cfg(AcpiGhesState *ags, FWCfgState *s,
/* Create a read-write fw_cfg file for Address */
fw_cfg_add_file_callback(s, ACPI_HW_ERROR_ADDR_FW_CFG_FILE, NULL, NULL,
- NULL, &(ags->ghes_addr_le), sizeof(ags->ghes_addr_le), false);
+ NULL, &(ags->hw_error_le), sizeof(ags->hw_error_le), false);
ags->present = true;
}
@@ -391,7 +391,7 @@ void ghes_record_cper_errors(const void *cper, size_t len,
}
ags = &acpi_ged_state->ghes_state;
- start_addr = le64_to_cpu(ags->ghes_addr_le);
+ start_addr = le64_to_cpu(ags->hw_error_le);
start_addr += source_id * sizeof(uint64_t);
diff --git a/include/hw/acpi/ghes.h b/include/hw/acpi/ghes.h
index a35097d5207c..9a765edb27ef 100644
--- a/include/hw/acpi/ghes.h
+++ b/include/hw/acpi/ghes.h
@@ -65,7 +65,7 @@ enum {
};
typedef struct AcpiGhesState {
- uint64_t ghes_addr_le;
+ uint64_t hw_error_le;
bool present; /* True if GHES is present at all on this board */
} AcpiGhesState;
--
2.47.0
- [PATCH v3 01/15] acpi/ghes: get rid of ACPI_HEST_SRC_ID_RESERVED, (continued)
- [PATCH v3 01/15] acpi/ghes: get rid of ACPI_HEST_SRC_ID_RESERVED, Mauro Carvalho Chehab, 2024/11/12
- [PATCH v3 09/15] acpi/ghes: better name GHES memory error function, Mauro Carvalho Chehab, 2024/11/12
- [PATCH v3 06/15] acpi/ghes: Remove a duplicated out of bounds check, Mauro Carvalho Chehab, 2024/11/12
- [PATCH v3 10/15] acpi/ghes: don't crash QEMU if ghes GED is not found, Mauro Carvalho Chehab, 2024/11/12
- [PATCH v3 07/15] acpi/ghes: Change the type for source_id, Mauro Carvalho Chehab, 2024/11/12
- [PATCH v3 05/15] acpi/ghes: Fix acpi_ghes_record_errors() argument, Mauro Carvalho Chehab, 2024/11/12
- [PATCH v3 15/15] docs: acpi_hest_ghes: fix documentation for CPER size, Mauro Carvalho Chehab, 2024/11/12
- [PATCH v3 13/15] acpi/ghes: move offset calculus to a separate function, Mauro Carvalho Chehab, 2024/11/12
- [PATCH v3 12/15] acpi/ghes: better name the offset of the hardware error firmware,
Mauro Carvalho Chehab <=
- [PATCH v3 08/15] acpi/ghes: make the GHES record generation more generic, Mauro Carvalho Chehab, 2024/11/12
- [PATCH v3 14/15] acpi/ghes: Change ghes fill logic to work with only one source, Mauro Carvalho Chehab, 2024/11/12