[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH-for-10.0 5/6] accel/tcg: Add TCGCPUOps::arch_id field
From: |
Anton Johansson |
Subject: |
Re: [PATCH-for-10.0 5/6] accel/tcg: Add TCGCPUOps::arch_id field |
Date: |
Wed, 27 Nov 2024 18:26:03 +0100 |
On 27/11/24, Philippe Mathieu-Daudé wrote:
> When using multiple TCG frontends concurrently, we need to
> be able to discriminate by target architecture. While we
> can infer that from the CPUClass, it can be quicker to get
> it from a direct field in TCGCPUOps.
>
> Signed-off-by: Philippe Mathieu-Daudé <philmd@linaro.org>
> ---
> include/hw/core/tcg-cpu-ops.h | 3 +++
> target/alpha/cpu.c | 1 +
> target/arm/cpu.c | 1 +
> target/arm/tcg/cpu-v7m.c | 1 +
> target/avr/cpu.c | 1 +
> target/hexagon/cpu.c | 1 +
> target/hppa/cpu.c | 1 +
> target/i386/tcg/tcg-cpu.c | 1 +
> target/loongarch/cpu.c | 1 +
> target/m68k/cpu.c | 1 +
> target/microblaze/cpu.c | 1 +
> target/mips/cpu.c | 1 +
> target/openrisc/cpu.c | 1 +
> target/ppc/cpu_init.c | 1 +
> target/riscv/tcg/tcg-cpu.c | 1 +
> target/rx/cpu.c | 1 +
> target/s390x/cpu.c | 1 +
> target/sh4/cpu.c | 1 +
> target/sparc/cpu.c | 1 +
> target/tricore/cpu.c | 1 +
> target/xtensa/cpu.c | 1 +
> 21 files changed, 23 insertions(+)
Reviewed-by: Anton Johansson <anjo@rev.ng>
- Re: [PATCH-for-10.0 1/6] target/ppc: Indent ppc_tcg_ops[] with 4 spaces, (continued)
- [PATCH-for-10.0 2/6] accel/tcg: Declare local tcg_ops variable in tcg_exec_realizefn(), Philippe Mathieu-Daudé, 2024/11/27
- [PATCH-for-10.0 4/6] include: Expose QemuArch in 'qemu/arch_id.h', Philippe Mathieu-Daudé, 2024/11/27
- [PATCH-for-10.0 5/6] accel/tcg: Add TCGCPUOps::arch_id field, Philippe Mathieu-Daudé, 2024/11/27
- [PATCH-for-10.0 3/6] accel/tcg: Rename TCGCPUOps::initialize() as initialize_once(), Philippe Mathieu-Daudé, 2024/11/27
- [PATCH-for-10.0 6/6] accel/tcg: Allow tcg_exec_realizefn() initialize multiple frontends, Philippe Mathieu-Daudé, 2024/11/27