|
From: | Wojtek Kaniewski |
Subject: | Re: [avr-gcc-list] Re: [avr-libc-dev] RFD: more avr-libc API changes |
Date: | Thu, 08 Sep 2005 22:11:31 +0200 |
User-agent: | Mozilla Thunderbird 1.0.6 (X11/20050716) |
Joerg Wunsch wrote):
How about changing the name to "ISR," which would do the same thing as the existing "SIGNAL"?Then, SIGNAL and INTERRUPT can both be deprecated (avoiding future confusion).It has been suggested before, but so far, nobody else seemed to care about that suggestion. I'm open for it. I'd probably rather deprecate SIGNAL with a much lower priority than INTERRUPT, as there's no strong need to force that change upon virtually every AVR-GCC program around, but I don't mind such a change.
How about... #define VECTOR(signame) \ void SIG_ ## signame (void) __attribute__ ((interrupt)); \ void SIG_ ## signame (void) This way it would get closer to Atmel's datasheets. Instead of... SIGNAL(SIG_ADC) { // ... } one could simply use: VECTOR(ADC) { // ... }I'm aware that there's already _VECTOR(x) macro, but as it's internal to avr-libc, it shouldn't cause any confustion.
Regards, Wojtek
[Prev in Thread] | Current Thread | [Next in Thread] |