[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Debian-sf-devel] [ 101223 ] Hang when Activating a new Project

From: nobody
Subject: [Debian-sf-devel] [ 101223 ] Hang when Activating a new Project
Date: Tue, 27 Aug 2002 23:15:38 -0400

Support Request #101223, was updated on 2002-Aug-25 07:32
You can respond by visiting:

Category: None
Status: Open
Priority: 5
Summary: Hang when Activating a new Project

By: leif
Date: 2002-Aug-28 03:15
Logged In: YES 
Browser: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0rc2) 
Gecko/20020512 Netscape/7.0b1

Sorry about posting to the wrong place.  But this was a
support request, not a bug. :-)  I figured is was my problem.

I read through the archives, but nobody had mentioned the
case where PHP would hang on the ldap_connect call.  After
fiddling with lots of settings, the hung suddenly went away
and I started getting Cannot connect errors.  Haven't a clue
what changed though. :-/

All of the below command line tests were working perfectly
but from source forge the php_connect was still failing.

Going back in and trying some test PHP pages, I found that
they worked, while SF did not.  It turns out that source
forge was connecting to the fully qualified host name, while
my test script was connecting to localhost.

Doing a ping, I realized that the name was resolving to my
external rather than local IP address.  Bingo.  Fixed that
and it all worked beautifully.

Thanks for your help,


By: girardot
Date: 2002-Aug-25 17:33
Logged In: YES 
Browser: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

You don't say what debugging told you, nor can i tell what 
version of debain-sf you might be using.

The reference in your post seems to be a compiling problem 
with php, but you you obviously have php compiled on your 
box right ? I mean php runs and is compiled, the problem is 
really something to do with your connection to the ldap 
server ?

What did _your_ debugging output? Please put in any actual 
error messages you can find, that is the only way to tell 
what the problem is.

Unless i am miss understanding something about that link 
you posted, it seems totally irrelevent to your issue here.

Can anything connect to your ldap sever?

Make sure whatver router or NAT box you have is allowing 
ldap to pass. Approving projects connects to the ldap 
server via name.

Use the ldapsearch program to see if you can talk to your 
ldap server at all:
/usr/bin/ldapsearch -v -v -h localhost 'objectClass=*'
ldapsearch -v -v -h 'objectClass=*'

what do those say? cannot bind or 
ldap_sasl_interactive_bind_s: No such attribute ?

you should get an error of some sort, if it is cannot bind 
to server in the one with your host name then you are 
probably not passing ldap to your sf box.

And consider searching the mailing list archives for ldap 
problems, its been discussed at lenght. you should really 
vet this out as a configuration issue on the help list 
before you assume its a bug. please post your problem again 
specifically and the results of your testing to the mailing 
list and not here.

You can respond by visiting:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]