[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Freeipmi-users] Password verification timeout after a BMC/firmware upgr

From: Chris Collins
Subject: [Freeipmi-users] Password verification timeout after a BMC/firmware upgrade
Date: Thu, 6 May 2021 11:54:06 +0000


I wondered if anyone could advise on some debugging help. I've been using 
freeipmi, specifically ipmi-sel for a while to gather detailed info from a 
bunch of Intel servers. However, after a long overdue bios/bmc/firmware update 
session, I can no long connect with freeipmi tools and now get a password 
verification timeout message. This is using the same credentials that still 
work with ipmitool. Comparison between a non-working example and working (not 
yet updated) node below, including:

# ./ipmi-sel -h host001-bmc -u ADMIN -p REDACTED --output-event-state 
./ipmi-sel: password verification timeout

# ./ipmi-sel -h host002-bmc -u ADMIN -p REDACTED --output-event-state 
ID  | Date        | Time     | Name             | Type                        | 
State    | Event
<prints out fine>

# ipmitool -I lanplus -U ADMIN -P REDACTED -H host001-bmc sel list
   <prints out fine>

# ipmitool -I lanplus -U ADMIN -P REDACTED -H host002-bmc sel list
   <prints out fine>

Having read through various comments on this mailing list based on similar 
things, I've reviewed the output of "ipmi-config --checkout -vv" between this 
and another working machine, and updated a few of the settings I've noticed 
different that look like they could be relevant (and done an "ipmitool mc reset 
cold" afterwards) but no luck.

I've also tried some of the workaround flags such as 
noauthcodecheck,intel20,nochecksumcheck but again no luck.

I have struggled to get any further verbose info out of ipmi-sel, just that 
message. Just in case it provides I have also tried ipmiutil, which also 
doesn't work, providing the following output:

# bin/ipmiutil sel host001-bmc -u ADMIN -p REDACTED
ipmiutil sel version 3.17
ipmilan_open_session error, rv = -3
ipmilan receive from BMC failed
ipmi_open error = -3 receive from BMC failed
ipmiutil sel, receive from BMC failed

Running ipmi-sel locally on the host in question works fine btw....

Any suggestions would be appreciated - the additional detail freeipmi gives 
over ipmitool is really useful!



reply via email to

[Prev in Thread] Current Thread [Next in Thread]