[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Freeipmi-users] Password verification timeout after a BMC/firmware

From: Chris Collins
Subject: Re: [Freeipmi-users] Password verification timeout after a BMC/firmware upgrade
Date: Mon, 10 May 2021 08:43:08 +0000

Hi Al,

Thanks for the suggestion - I had previously tried the '-D lan_2_0' option and 
when that didn't work and I disregarded it. After your suggestion though I did 
a little more investigation and the combination of that plus the opensesspriv 
workaround which I'd somehow failed to notice before, it is now back working 

Brilliant, thanks very much!


From: Al Chu <>
Sent: 08 May 2021 15:37:37
To: Chris Collins;
Subject: Re: [Freeipmi-users] Password verification timeout after a 
BMC/firmware upgrade

Hi Chris,

I will admit I'm at a bit of a loss why it wouldn't work anymore.  I
notice w/ ipmitool below you used `-I lanplus`. The equivalent in
FreeIPMI would be `-D lan_2_0` so that may be worth trying as well
(potentially w/ workaround options too).

My only (potentially stupid) guess is that Intel removed some older
IPMI 1.5 support.  It has known security issues with certain configs,
hard to know for sure without seeing your config.

If the -D `lan_2_0` option doesn't work, could you send me some --debug
output.  I don't know what I'm looking for exactly, but it's a start.


On Thu, 2021-05-06 at 11:54 +0000, Chris Collins via Freeipmi-users
> Hi,
> I wondered if anyone could advise on some debugging help. I've been
> using freeipmi, specifically ipmi-sel for a while to gather detailed
> info from a bunch of Intel servers. However, after a long overdue
> bios/bmc/firmware update session, I can no long connect with freeipmi
> tools and now get a password verification timeout message. This is
> using the same credentials that still work with ipmitool. Comparison
> between a non-working example and working (not yet updated) node
> below, including:
> # ./ipmi-sel -h host001-bmc -u ADMIN -p REDACTED --output-event-state
> --interpret-oem-data
> ./ipmi-sel: password verification timeout
> # ./ipmi-sel -h host002-bmc -u ADMIN -p REDACTED --output-event-state
> --interpret-oem-data
> ID  | Date        | Time     | Name             |
> Type                        | State    | Event
> <prints out fine>
> # ipmitool -I lanplus -U ADMIN -P REDACTED -H host001-bmc sel list
>    <prints out fine>
> # ipmitool -I lanplus -U ADMIN -P REDACTED -H host002-bmc sel list
>    <prints out fine>
> Having read through various comments on this mailing list based on
> similar things, I've reviewed the output of "ipmi-config --checkout
> -vv" between this and another working machine, and updated a few of
> the settings I've noticed different that look like they could be
> relevant (and done an "ipmitool mc reset cold" afterwards) but no
> luck.
> I've also tried some of the workaround flags such as
> noauthcodecheck,intel20,nochecksumcheck but again no luck.
> I have struggled to get any further verbose info out of ipmi-sel,
> just that message. Just in case it provides I have also tried
> ipmiutil, which also doesn't work, providing the following output:
> # bin/ipmiutil sel host001-bmc -u ADMIN -p REDACTED
> ipmiutil sel version 3.17
> ipmilan_open_session error, rv = -3
> ipmilan receive from BMC failed
> ipmi_open error = -3 receive from BMC failed
> ipmiutil sel, receive from BMC failed
> Running ipmi-sel locally on the host in question works fine btw....
> Any suggestions would be appreciated - the additional detail freeipmi
> gives over ipmitool is really useful!
> Thanks,
> Chris
> _______________________________________________
> Freeipmi-users mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]