gnustep-dev
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Question on GSDrawingFunctions


From: Jeff Teunissen
Subject: Re: Question on GSDrawingFunctions
Date: Mon, 02 Feb 2004 08:03:25 -0500

Fred Kiefer wrote:

[snip]

> I don't want to upset you, but there may have been a misunderstanding.

No need to worry about upsetting me -- it's a rather difficult thing to do.
You may have mistaken my peculiar style for upset, but it wasn't.

[snip]

> It may be strange, but this time I am on your side (at least I tried to
> be).

I don't really have a side in this regard. :) I did the drawing of NSBox
based on how things looked on OPENSTEP, and that was used by Adam to
implement the GSDrawFunctions class. I only did it because Alex Perez has
non-default colors and he thought I had hardcoded some colors in
Preferences's UI. To prove I hadn't, I fixed NSBox.

> Once more: I don't want to change the implementation of the bezel
> drawing functions to use GSDrawingFunctions. (It was me that prevented a
> similar change some time ago) But perhaps we could correct the existing
> implementation if we find it was wrong. And I really would like to see
> more GSDrawingFunctions code used in the GNUstep widget drawing.

As would I.

> >>There is also a small difference in the implementation of
> >>NSDrawGrayBezel and DrawDarkBezel. The second round of lines are drawn
> >>in a different order. This only is visible on very close inspection,
> >>still I wonder which way is correct and if we should change them to be
> >>the same. Again input from somebody with a reference impementation
> >> would be welcome.
> >
> >
> > The result of DarkBezel (with default colors) is the same as OPENSTEP
> > 4 NSDrawGrayBezel.
> 
> This should answer the second question. So the old code in
> NSDrawGrayBezel was wrong. Which just leaves the first question: Why did
> you call this DrawDarkBezel and not DrawGrayBezel? Is there a difference
> or not? And would you mind to send me a screen shot of the OpenStep
> result of NSDrawDarkBezel and NSDrawGrayBezel. With all this
> misunderstandings it seems better to check myself.

I didn't give them their names, I presume Adam did that when he wrote the
class based on what I did with NSBox. I would eliminate +drawLightBezel::
and rename +drawDarkBezel:: to +drawBezel::, because the difference only
seems to be in the color of the fill -- which neither method performs.

> Up to now my understanding, based on the names of the functions, was
> that there used to be a series going from light to dark:
> NSDrawWhiteBezel
> NSDrawLightBezel
> NSDrawGrayBezel
> NSDrawDarkBezel

No, the only bezel functions are White and (Light)Gray. And since the whole
thing was done with exactly four grey shades, that's all that was possible
-- because a bezel draw needs two colors to be darker than the contents,
anything darker than light grey could not be drawn on a 2-bit display.

> Even if we change the colours we use, we should stick with the
> differences, if there where any.

I think this is wrong. We should not say we're drawing grey when in reality
we are drawing purple, and this is what both "White"/"Gray" and
"Light"/"Dark" do.

-- 
| Jeff Teunissen  -=-  Pres., Dusk To Dawn Computing  -=-  deek @ d2dc.net
| GPG: 1024D/9840105A   7102 808A 7733 C2F3 097B  161B 9222 DAB8 9840 105A
| Core developer, The QuakeForge Project        http://www.quakeforge.net/
| Specializing in Debian GNU/Linux              http://www.d2dc.net/~deek/




reply via email to

[Prev in Thread] Current Thread [Next in Thread]