[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Health-dev] Install GNU Health from source

From: Emilien Klein
Subject: Re: [Health-dev] Install GNU Health from source
Date: Wed, 24 Oct 2012 21:31:34 +0200

Hi Luis and the GNU Health developers,

So I've started fresh, and installed both Tryton and GNU Health from
source. Sadly I still get the same "unmet dependencies" error message
as soon as I've run "make install". Any idea about what I'm doing

Starting on a fresh Debian Sid (unstable), I've executed the following commands:

$ sudo aptitude install python-lxml python-relatorio python-dateutil
python-psycopg2 python-tz python-polib python-ldap python-vobject
$ mkdir ~/bin
$ cd ~/bin
$ wget
$ tar -xf trytond-2.4.1.tar.gz
$ wget
$ tar -xf tryton-2.4.1.tar.gz
$ cd trytond-2.4.1/
$ python install --user
$ cd ../tryton-2.4.1/
$ python install --user

<Tryton is installed, let's configure Postgres to be a bit less paranoid>

$ sudo passwd postgres
<changed password to "postgres", use this for the next step>
$ su - postgres -c "createuser --createdb --no-createrole
--no-superuser --pwprompt <USERNAME>"
(replace <USERNAME> with the username you are currently logged in with)
$ sudo nano /etc/postgresql/9.1/main/pg_hba.conf

<change "peer" and "mdr" by "trust":
Replace "local   all             all                                     peer"
By "local   all             all                                     trust"
Replace "host    all             all               mdr"
By "host    all             all               trust"

$ sudo /etc/init.d/postgresql* restart

<Let's start Tryton up>

$ ~/.local/bin/trytond -v
$ ~/.local/bin/tryton

<At this point Tryton starts properly>
<Create a new profile (localhost:8000) and a new database (gnuhealth)>
<Stop Tryton (both previous commands)>
<Let's download GNU Health and install it>

$ cd ~/bin
$ wget
$ tar -xf gnuhealth-1.6.3.tar.gz
$ cd gnuhealth-1.6.3/
$ ./configure 
$ make install

<Now GNU Health is installed, let's restart Tryton>

$ ~/.local/bin/trytond -v
$ ~/.local/bin/tryton

<After logging into Tryton, the following error happens>

address@hidden:~$ .local/bin/tryton
ERROR:common.message:Traceback (most recent call last):
  File "/trytond/protocols/", line 123, in _marshaled_dispatch
    response['result'] = dispatch_method(method, params)
  File "/trytond/protocols/", line 156, in _dispatch
    res = dispatch(*args)
  File "/trytond/protocols/", line 36, in dispatch
    res = security.login(database_name, user, session)
  File "/trytond/", line 19, in login
    pool = _get_pool(dbname)
  File "/trytond/", line 13, in _get_pool
  File "/trytond/", line 113, in init
  File "/trytond/", line 64, in start
  File "/trytond/modules/", line 317, in register_classes
    for package in create_graph(get_module_list())[0]:
  File "/trytond/modules/", line 187, in create_graph
    raise Exception('%s unmet dependencies: %s' % (package, missings))
Exception: health_mdg6 unmet dependencies: ['health', 'health_lab']

health_mdg6 unmet dependencies: ['health', 'health_lab']

The "funny" part is that if you log into Tryton using a wrong
password, you will still see the same error message...
Looking at the steps I followed, is there something you see I'm missing?

P.S.: Please CC me, as I'm not subscribed to this list.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]