help-cfengine
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

v2.1.13 not sending out e-mail


From: David Cress
Subject: v2.1.13 not sending out e-mail
Date: Wed, 03 Aug 2005 16:00:03 -0400
User-agent: Mozilla Thunderbird 1.0.6 (X11/20050720)

cfexecd is giving me the following error:

Unknown host: web.turner.com
Make sure that fully qualified names can be looked up at your site!
i.e. www.gnu.org, not just www. If you use NIS or /etc/hosts
make sure that the full form is registered too as an alias!

I added web to /etc/hosts just to make sure, same error.  It resolves in
DNS just fine.  As you can see in the defined objects below, sunman, is
the policy/file host.  It's only in DNS and it seems to work fine.

DEFINED MACRO/VARIABLES (by contexts)

OBJECT: global
   4759 : ipv4[bge0]=10.188.129.83

OBJECT: update
   163 : cf_install_dir=/opt/cfengine/sbin
   1800 : smtpserver=web.turner.com
   2142 : SplayTime=5
   2697 : policyhost=sunman.turner.com
   3626 : workdir=/var/cfengine
   4789 : master_cfinput=/master/inputs

OBJECT: main
   1487 : ChecksumDatabase=/var/cfengine/security.db
   1737 : ChecksumUpdates=true
   1800 : smtpserver=web.turner.com
   2412 : filehost=sunman.turner.com
   4902 : OS=solaris

If I put the smtpserver statement only in cfupdate.conf, then I get an
$(smtpserver) error message.  If only in cfagent.conf, or in both I get
this error.

cfagnet.conf
  control:
    domain = ( turner.com )
    smtpserver = ( web.turner.com )
    sysadm = ( address@hidden )

I've also tried with quotes, still the same error.


-- 
David Cress
Lead Engineer
CNN Internet Technologies
http://www.cnn.com
--------------------
(404) 878-1921

What exists, exists; what is, is.




reply via email to

[Prev in Thread] Current Thread [Next in Thread]