[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Lynx-dev] "-underscore" not working

From: Thomas Dickey
Subject: Re: [Lynx-dev] "-underscore" not working
Date: Sun, 31 Oct 2010 16:06:33 -0400 (EDT)

On Sun, 31 Oct 2010, siznax wrote:

On 10/31/10 12:26 PM, Thomas Dickey wrote:
On Sun, 31 Oct 2010, siznax wrote:
do i not understand this option really, or am i using this switch
incorrectly? i've tried SUBSTITUTE_UNDERSCORES:TRUE in my global
lynx.cfg, but still get the same result with:

hmm - no. A quick read of the code's showing me that the problem may be
that underline mode for dumps isn't provided in the (default) color-style

thanks for resonding.

so, is this a bug? or can i change my config somehow as a

color-style is a compile-time feature (you'd have to recompile lynx to
change it).  If you need advice on this, this is the place to ask...

workaround? sorry, i'm not familiar with the color-style
configuration options. i'm really only interested in the
-dump features.

btw, is there a way to force double-spacing of line breaks,
or turn off wrapping altogether? i've been resorting to dumb
stuff like this:

no... lynx is storing chunks of lines in buckets no bigger than 1024.

(it's "possible" to recompile with a bigger bucket-size, but not well-tested)

 lynx -dump -width=102400 BAD_HTML | sed G

where BAD_HTML = doesn't use
the P tag. so, the 100KB width gives me (hopefully) full
paragraphs, and "sed G" preserves the space between the
breaks. unfortunatey, there is much BAD_HTML. ;-)


Thomas E. Dickey

reply via email to

[Prev in Thread] Current Thread [Next in Thread]