[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[Qemu-devel] [PULL 10/33] softmmu: move softmmu_template.h out of includ
From: |
Paolo Bonzini |
Subject: |
[Qemu-devel] [PULL 10/33] softmmu: move softmmu_template.h out of include/ |
Date: |
Thu, 5 Jun 2014 16:22:00 +0200 |
It is only included in cputlb.c now.
Reviewed-by: Richard Henderson <address@hidden>
Signed-off-by: Paolo Bonzini <address@hidden>
---
cputlb.c | 16 ++++++++--------
include/exec/softmmu_template.h => softmmu_template.h | 0
2 files changed, 8 insertions(+), 8 deletions(-)
rename include/exec/softmmu_template.h => softmmu_template.h (100%)
diff --git a/cputlb.c b/cputlb.c
index 0a884f8..e70cf7a 100644
--- a/cputlb.c
+++ b/cputlb.c
@@ -334,16 +334,16 @@ tb_page_addr_t get_page_addr_code(CPUArchState *env1,
target_ulong addr)
#define MMUSUFFIX _mmu
#define SHIFT 0
-#include "exec/softmmu_template.h"
+#include "softmmu_template.h"
#define SHIFT 1
-#include "exec/softmmu_template.h"
+#include "softmmu_template.h"
#define SHIFT 2
-#include "exec/softmmu_template.h"
+#include "softmmu_template.h"
#define SHIFT 3
-#include "exec/softmmu_template.h"
+#include "softmmu_template.h"
#undef MMUSUFFIX
#define MMUSUFFIX _cmmu
@@ -354,13 +354,13 @@ tb_page_addr_t get_page_addr_code(CPUArchState *env1,
target_ulong addr)
#define SOFTMMU_CODE_ACCESS
#define SHIFT 0
-#include "exec/softmmu_template.h"
+#include "softmmu_template.h"
#define SHIFT 1
-#include "exec/softmmu_template.h"
+#include "softmmu_template.h"
#define SHIFT 2
-#include "exec/softmmu_template.h"
+#include "softmmu_template.h"
#define SHIFT 3
-#include "exec/softmmu_template.h"
+#include "softmmu_template.h"
diff --git a/include/exec/softmmu_template.h b/softmmu_template.h
similarity index 100%
rename from include/exec/softmmu_template.h
rename to softmmu_template.h
--
1.8.3.1
- [Qemu-devel] [PULL 01/33] cputlb: Fix regression with TCG interpreter (bug 1310324), (continued)
- [Qemu-devel] [PULL 01/33] cputlb: Fix regression with TCG interpreter (bug 1310324), Paolo Bonzini, 2014/06/05
- [Qemu-devel] [PULL 02/33] nseries: clean up coding style, Paolo Bonzini, 2014/06/05
- [Qemu-devel] [PULL 03/33] hw: use ld_p/st_p instead of ld_raw/st_raw, Paolo Bonzini, 2014/06/05
- [Qemu-devel] [PULL 04/33] softmmu: start introducing SOFTMMU_CODE_ACCESS in softmmu_header.h, Paolo Bonzini, 2014/06/05
- [Qemu-devel] [PULL 06/33] softmmu: move definition of CPU_MMU_INDEX to inclusion site, drop ACCESS_TYPE, Paolo Bonzini, 2014/06/05
- [Qemu-devel] [PULL 07/33] softmmu: make do_unaligned_access a method of CPU, Paolo Bonzini, 2014/06/05
- [Qemu-devel] [PULL 08/33] softmmu: move ALIGNED_ONLY to cpu.h, Paolo Bonzini, 2014/06/05
- [Qemu-devel] [PULL 05/33] softmmu: move MMUSUFFIX under SOFTMMU_CODE_ACCESS, Paolo Bonzini, 2014/06/05
- [Qemu-devel] [PULL 09/33] softmmu: commonize helper definitions, Paolo Bonzini, 2014/06/05
- [Qemu-devel] [PULL 12/33] softmmu: introduce cpu_ldst.h, Paolo Bonzini, 2014/06/05
- [Qemu-devel] [PULL 10/33] softmmu: move softmmu_template.h out of include/,
Paolo Bonzini <=
- [Qemu-devel] [PULL 11/33] target-arm: move arm_*_code to a separate file, Paolo Bonzini, 2014/06/05
- [Qemu-devel] [PULL 13/33] softmmu: move all load/store functions to cpu_ldst.h, Paolo Bonzini, 2014/06/05
- [Qemu-devel] [PULL 16/33] target-i386: fix kernel accesses with SMAP and CPL = 3, Paolo Bonzini, 2014/06/05
- [Qemu-devel] [PULL 15/33] target-i386: move check_io helpers to seg_helper.c, Paolo Bonzini, 2014/06/05
- [Qemu-devel] [PULL 17/33] target-i386: simplify SMAP handling in MMU_KSMAP_IDX, Paolo Bonzini, 2014/06/05
- [Qemu-devel] [PULL 14/33] target-i386: rename KSMAP to KNOSMAP, Paolo Bonzini, 2014/06/05
- [Qemu-devel] [PULL 18/33] target-i386: fix coding standards in x86_cpu_handle_mmu_fault, Paolo Bonzini, 2014/06/05
- [Qemu-devel] [PULL 20/33] target-i386: commonize checks for 4MB and 4KB pages, Paolo Bonzini, 2014/06/05
- [Qemu-devel] [PULL 19/33] target-i386: commonize checks for 2MB and 4KB pages, Paolo Bonzini, 2014/06/05
- [Qemu-devel] [PULL 21/33] target-i386: commonize checks for PAE and non-PAE, Paolo Bonzini, 2014/06/05