qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH 08/63] vfio: Rename VFIO_AP_DEVICE_TYPE to TYPE_VFIO_AP_DEVIC


From: Thomas Huth
Subject: Re: [PATCH 08/63] vfio: Rename VFIO_AP_DEVICE_TYPE to TYPE_VFIO_AP_DEVICE
Date: Thu, 3 Sep 2020 13:35:42 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.6.0

On 03/09/2020 00.42, Eduardo Habkost wrote:
> This will make the type name constant consistent with the name of
> the type checking macro.
> 
> Signed-off-by: Eduardo Habkost <ehabkost@redhat.com>
> ---
> Cc: Cornelia Huck <cohuck@redhat.com>
> Cc: Thomas Huth <thuth@redhat.com>
> Cc: Christian Borntraeger <borntraeger@de.ibm.com>
> Cc: Tony Krowiak <akrowiak@linux.ibm.com>
> Cc: Halil Pasic <pasic@linux.ibm.com>
> Cc: Pierre Morel <pmorel@linux.ibm.com>
> Cc: Alex Williamson <alex.williamson@redhat.com>
> Cc: qemu-s390x@nongnu.org
> Cc: qemu-devel@nongnu.org
> ---
>  hw/vfio/ap.c | 8 ++++----
>  1 file changed, 4 insertions(+), 4 deletions(-)
> 
> diff --git a/hw/vfio/ap.c b/hw/vfio/ap.c
> index 68ed059b39..582c091a24 100644
> --- a/hw/vfio/ap.c
> +++ b/hw/vfio/ap.c
> @@ -30,7 +30,7 @@
>  #include "exec/address-spaces.h"
>  #include "qom/object.h"
>  
> -#define VFIO_AP_DEVICE_TYPE      "vfio-ap"
> +#define TYPE_VFIO_AP_DEVICE      "vfio-ap"
>  
>  struct VFIOAPDevice {
>      APDevice apdev;
> @@ -39,7 +39,7 @@ struct VFIOAPDevice {
>  typedef struct VFIOAPDevice VFIOAPDevice;
>  
>  DECLARE_INSTANCE_CHECKER(VFIOAPDevice, VFIO_AP_DEVICE,
> -                         VFIO_AP_DEVICE_TYPE)
> +                         TYPE_VFIO_AP_DEVICE)
>  
>  static void vfio_ap_compute_needs_reset(VFIODevice *vdev)
>  {
> @@ -72,7 +72,7 @@ static VFIOGroup *vfio_ap_get_group(VFIOAPDevice *vapdev, 
> Error **errp)
>  
>      if (!group_path) {
>          error_setg(errp, "%s: no iommu_group found for %s: %s",
> -                   VFIO_AP_DEVICE_TYPE, vapdev->vdev.sysfsdev, 
> gerror->message);
> +                   TYPE_VFIO_AP_DEVICE, vapdev->vdev.sysfsdev, 
> gerror->message);
>          g_error_free(gerror);
>          return NULL;
>      }
> @@ -176,7 +176,7 @@ static void vfio_ap_class_init(ObjectClass *klass, void 
> *data)
>  }
>  
>  static const TypeInfo vfio_ap_info = {
> -    .name = VFIO_AP_DEVICE_TYPE,
> +    .name = TYPE_VFIO_AP_DEVICE,
>      .parent = TYPE_AP_DEVICE,
>      .instance_size = sizeof(VFIOAPDevice),
>      .class_init = vfio_ap_class_init,
> 

Reviewed-by: Thomas Huth <thuth@redhat.com>




reply via email to

[Prev in Thread] Current Thread [Next in Thread]