qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[PATCH 11/63] edu: Rename TYPE_PCI_EDU_DEVICE to TYPE_EDU


From: Eduardo Habkost
Subject: [PATCH 11/63] edu: Rename TYPE_PCI_EDU_DEVICE to TYPE_EDU
Date: Wed, 2 Sep 2020 18:42:19 -0400

This will make the type name constant consistent with the name of
the type checking macro.

Signed-off-by: Eduardo Habkost <ehabkost@redhat.com>
---
Cc: Jiri Slaby <jslaby@suse.cz>
Cc: qemu-devel@nongnu.org
---
 hw/misc/edu.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/hw/misc/edu.c b/hw/misc/edu.c
index 0ff9d1ac78..b69728838d 100644
--- a/hw/misc/edu.c
+++ b/hw/misc/edu.c
@@ -33,10 +33,10 @@
 #include "qemu/module.h"
 #include "qapi/visitor.h"
 
-#define TYPE_PCI_EDU_DEVICE "edu"
+#define TYPE_EDU "edu"
 typedef struct EduState EduState;
 DECLARE_INSTANCE_CHECKER(EduState, EDU,
-                         TYPE_PCI_EDU_DEVICE)
+                         TYPE_EDU)
 
 #define FACT_IRQ        0x00000001
 #define DMA_IRQ         0x00000100
@@ -429,7 +429,7 @@ static void pci_edu_register_types(void)
         { },
     };
     static const TypeInfo edu_info = {
-        .name          = TYPE_PCI_EDU_DEVICE,
+        .name          = TYPE_EDU,
         .parent        = TYPE_PCI_DEVICE,
         .instance_size = sizeof(EduState),
         .instance_init = edu_instance_init,
-- 
2.26.2




reply via email to

[Prev in Thread] Current Thread [Next in Thread]