qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH 06/63] dev-smartcard-reader: Rename CCID_DEV_NAME to TYPE_USB


From: Philippe Mathieu-Daudé
Subject: Re: [PATCH 06/63] dev-smartcard-reader: Rename CCID_DEV_NAME to TYPE_USB_CCID_DEV
Date: Thu, 3 Sep 2020 14:50:29 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.11.0

On 9/3/20 12:42 AM, Eduardo Habkost wrote:
> This will make the type name constant consistent with the name of
> the type checking macro.
> 
> Signed-off-by: Eduardo Habkost <ehabkost@redhat.com>

Reviewed-by: Philippe Mathieu-Daudé <philmd@redhat.com>

> ---
> Cc: Gerd Hoffmann <kraxel@redhat.com>
> Cc: qemu-devel@nongnu.org
> ---
>  hw/usb/dev-smartcard-reader.c | 8 ++++----
>  1 file changed, 4 insertions(+), 4 deletions(-)
> 
> diff --git a/hw/usb/dev-smartcard-reader.c b/hw/usb/dev-smartcard-reader.c
> index 432508c478..59b2248f34 100644
> --- a/hw/usb/dev-smartcard-reader.c
> +++ b/hw/usb/dev-smartcard-reader.c
> @@ -60,10 +60,10 @@ do { \
>  #define D_MORE_INFO 3
>  #define D_VERBOSE 4
>  
> -#define CCID_DEV_NAME "usb-ccid"
> +#define TYPE_USB_CCID_DEV "usb-ccid"
>  typedef struct USBCCIDState USBCCIDState;
>  DECLARE_INSTANCE_CHECKER(USBCCIDState, USB_CCID_DEV,
> -                         CCID_DEV_NAME)
> +                         TYPE_USB_CCID_DEV)
>  /*
>   * The two options for variable sized buffers:
>   * make them constant size, for large enough constant,
> @@ -1462,7 +1462,7 @@ static void ccid_class_initfn(ObjectClass *klass, void 
> *data)
>  }
>  
>  static const TypeInfo ccid_info = {
> -    .name          = CCID_DEV_NAME,
> +    .name          = TYPE_USB_CCID_DEV,
>      .parent        = TYPE_USB_DEVICE,
>      .instance_size = sizeof(USBCCIDState),
>      .class_init    = ccid_class_initfn,
> @@ -1495,7 +1495,7 @@ static void ccid_register_types(void)
>      type_register_static(&ccid_bus_info);
>      type_register_static(&ccid_card_type_info);
>      type_register_static(&ccid_info);
> -    usb_legacy_register(CCID_DEV_NAME, "ccid", NULL);
> +    usb_legacy_register(TYPE_USB_CCID_DEV, "ccid", NULL);
>  }
>  
>  type_init(ccid_register_types)
> 




reply via email to

[Prev in Thread] Current Thread [Next in Thread]