qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH 14/63] i8254: Rename TYPE_I8254 to TYPE_PIT


From: Philippe Mathieu-Daudé
Subject: Re: [PATCH 14/63] i8254: Rename TYPE_I8254 to TYPE_PIT
Date: Thu, 3 Sep 2020 14:47:03 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.11.0

On 9/3/20 12:42 AM, Eduardo Habkost wrote:
> This will make the type name constant consistent with the name of
> the type checking macro.
> 
> Signed-off-by: Eduardo Habkost <ehabkost@redhat.com>
> ---
> Cc: "Michael S. Tsirkin" <mst@redhat.com>
> Cc: Paolo Bonzini <pbonzini@redhat.com>
> Cc: qemu-devel@nongnu.org
> ---
>  include/hw/timer/i8254.h | 4 ++--
>  hw/timer/i8254.c         | 4 ++--
>  2 files changed, 4 insertions(+), 4 deletions(-)
> 
> diff --git a/include/hw/timer/i8254.h b/include/hw/timer/i8254.h
> index 1a522a2457..ddd925074f 100644
> --- a/include/hw/timer/i8254.h
> +++ b/include/hw/timer/i8254.h
> @@ -45,7 +45,7 @@ typedef struct PITCommonClass PITCommonClass;
>  DECLARE_OBJ_CHECKERS(PITCommonState, PITCommonClass,
>                       PIT_COMMON, TYPE_PIT_COMMON)
>  
> -#define TYPE_I8254 "isa-pit"
> +#define TYPE_PIT "isa-pit"

I disagree with this patch, as we have various PIT and only one I8254.

>  #define TYPE_KVM_I8254 "kvm-pit"
>  
>  static inline ISADevice *i8254_pit_init(ISABus *bus, int base, int isa_irq,
> @@ -54,7 +54,7 @@ static inline ISADevice *i8254_pit_init(ISABus *bus, int 
> base, int isa_irq,
>      DeviceState *dev;
>      ISADevice *d;
>  
> -    d = isa_new(TYPE_I8254);
> +    d = isa_new(TYPE_PIT);
>      dev = DEVICE(d);
>      qdev_prop_set_uint32(dev, "iobase", base);
>      isa_realize_and_unref(d, bus, &error_fatal);
> diff --git a/hw/timer/i8254.c b/hw/timer/i8254.c
> index c01ee2c72a..86f455f67e 100644
> --- a/hw/timer/i8254.c
> +++ b/hw/timer/i8254.c
> @@ -39,7 +39,7 @@
>  
>  typedef struct PITClass PITClass;
>  DECLARE_CLASS_CHECKERS(PITClass, PIT,
> -                       TYPE_I8254)
> +                       TYPE_PIT)
>  
>  struct PITClass {
>      PITCommonClass parent_class;
> @@ -370,7 +370,7 @@ static void pit_class_initfn(ObjectClass *klass, void 
> *data)
>  }
>  
>  static const TypeInfo pit_info = {
> -    .name          = TYPE_I8254,
> +    .name          = TYPE_PIT,
>      .parent        = TYPE_PIT_COMMON,
>      .instance_size = sizeof(PITCommonState),
>      .class_init    = pit_class_initfn,
> 




reply via email to

[Prev in Thread] Current Thread [Next in Thread]