qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH 16/63] i8259: Rename TYPE_KVM_I8259 to TYPE_KVM_PIC


From: Philippe Mathieu-Daudé
Subject: Re: [PATCH 16/63] i8259: Rename TYPE_KVM_I8259 to TYPE_KVM_PIC
Date: Thu, 3 Sep 2020 14:53:52 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.11.0

On 9/3/20 12:42 AM, Eduardo Habkost wrote:
> This will make the type name constant consistent with the name of
> the type checking macro.
> 
> Signed-off-by: Eduardo Habkost <ehabkost@redhat.com>
> ---
> Cc: "Michael S. Tsirkin" <mst@redhat.com>
> Cc: Marcel Apfelbaum <marcel.apfelbaum@gmail.com>
> Cc: Paolo Bonzini <pbonzini@redhat.com>
> Cc: Richard Henderson <rth@twiddle.net>
> Cc: Eduardo Habkost <ehabkost@redhat.com>
> Cc: qemu-devel@nongnu.org
> ---
>  hw/i386/kvm/i8259.c | 10 +++++-----
>  1 file changed, 5 insertions(+), 5 deletions(-)
> 
> diff --git a/hw/i386/kvm/i8259.c b/hw/i386/kvm/i8259.c
> index 3f8bf69e9c..687c0cd536 100644
> --- a/hw/i386/kvm/i8259.c
> +++ b/hw/i386/kvm/i8259.c
> @@ -19,10 +19,10 @@
>  #include "sysemu/kvm.h"
>  #include "qom/object.h"
>  
> -#define TYPE_KVM_I8259 "kvm-i8259"
> +#define TYPE_KVM_PIC "kvm-i8259"

I disagree with this patch, as we have various KVM INTC and only one
KVM_I8259.

TYPE_KVM_ARM_GIC and TYPE_KVM_S390_FLIC are kind of TYPE_KVM_INTC ...

Can we rename it KVM_I8259_PIC?

>  typedef struct KVMPICClass KVMPICClass;
>  DECLARE_CLASS_CHECKERS(KVMPICClass, KVM_PIC,
> -                       TYPE_KVM_I8259)
> +                       TYPE_KVM_PIC)
>  
>  /**
>   * KVMPICClass:
> @@ -133,8 +133,8 @@ static void kvm_pic_realize(DeviceState *dev, Error 
> **errp)
>  
>  qemu_irq *kvm_i8259_init(ISABus *bus)
>  {
> -    i8259_init_chip(TYPE_KVM_I8259, bus, true);
> -    i8259_init_chip(TYPE_KVM_I8259, bus, false);
> +    i8259_init_chip(TYPE_KVM_PIC, bus, true);
> +    i8259_init_chip(TYPE_KVM_PIC, bus, false);
>  
>      return qemu_allocate_irqs(kvm_pic_set_irq, NULL, ISA_NUM_IRQS);
>  }
> @@ -152,7 +152,7 @@ static void kvm_i8259_class_init(ObjectClass *klass, void 
> *data)
>  }
>  
>  static const TypeInfo kvm_i8259_info = {
> -    .name = TYPE_KVM_I8259,
> +    .name = TYPE_KVM_PIC,
>      .parent = TYPE_PIC_COMMON,
>      .instance_size = sizeof(PICCommonState),
>      .class_init = kvm_i8259_class_init,
> 




reply via email to

[Prev in Thread] Current Thread [Next in Thread]