qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[PATCH 19/63] mptsas: Rename TYPE_MPTSAS1068 to TYPE_MPT_SAS


From: Eduardo Habkost
Subject: [PATCH 19/63] mptsas: Rename TYPE_MPTSAS1068 to TYPE_MPT_SAS
Date: Wed, 2 Sep 2020 18:42:27 -0400

This will make the type name constant consistent with the name of
the type checking macro.

Signed-off-by: Eduardo Habkost <ehabkost@redhat.com>
---
Cc: Paolo Bonzini <pbonzini@redhat.com>
Cc: Fam Zheng <fam@euphon.net>
Cc: qemu-devel@nongnu.org
---
 hw/scsi/mptsas.h | 4 ++--
 hw/scsi/mptsas.c | 2 +-
 2 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/hw/scsi/mptsas.h b/hw/scsi/mptsas.h
index b85ac1a5fc..c618f686a3 100644
--- a/hw/scsi/mptsas.h
+++ b/hw/scsi/mptsas.h
@@ -14,10 +14,10 @@
 
 typedef struct MPTSASRequest MPTSASRequest;
 
-#define TYPE_MPTSAS1068 "mptsas1068"
+#define TYPE_MPT_SAS "mptsas1068"
 typedef struct MPTSASState MPTSASState;
 DECLARE_INSTANCE_CHECKER(MPTSASState, MPT_SAS,
-                         TYPE_MPTSAS1068)
+                         TYPE_MPT_SAS)
 
 enum {
     DOORBELL_NONE,
diff --git a/hw/scsi/mptsas.c b/hw/scsi/mptsas.c
index 135e7d96e4..0dbb70c17b 100644
--- a/hw/scsi/mptsas.c
+++ b/hw/scsi/mptsas.c
@@ -1434,7 +1434,7 @@ static void mptsas1068_class_init(ObjectClass *oc, void 
*data)
 }
 
 static const TypeInfo mptsas_info = {
-    .name = TYPE_MPTSAS1068,
+    .name = TYPE_MPT_SAS,
     .parent = TYPE_PCI_DEVICE,
     .instance_size = sizeof(MPTSASState),
     .class_init = mptsas1068_class_init,
-- 
2.26.2




reply via email to

[Prev in Thread] Current Thread [Next in Thread]