[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[gpsd-dev] gpsd Build Error "stdatomic.h" Not Found; Ubuntu 14.04 + ARM

From: Gr Hudy
Subject: [gpsd-dev] gpsd Build Error "stdatomic.h" Not Found; Ubuntu 14.04 + ARM Cortex A-15
Date: Tue, 03 Jul 2018 16:13:08 -0600


Sorry to post, but I have a project for which I really need gpsd, and I seem to be having trouble building.

I have downloaded and unzipped the latest gpsd-3.17 to an nVidia Tegra Jetson Tk1. It is an ARM Cortex A-15 with 2Gb RAM, running Ubuntu 14.04.

Running scons causes it to perform the build process, but it fails part way through:

arm-linux-gnueabihf-gcc -pthread -o -c -fno-strict-aliasing -fPIC -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -DHAVE_SYS_TIMEPPS_H=1 -I/usr/include/python2.7 gpsclient.c
In file included from gpsclient.c:12:0:
compiler.h:71:27: fatal error: stdatomic.h: No such file or directory
     #include <stdatomic.h>
compilation terminated.

Earlier in the same invocation, scons reported that stdatomic.h WAS available:

Checking if compiler supplies __STDC_NO_ATOMICS__... no
Checking for C header file stdatomic.h... yes

Building the exact same gpsd-3.17 archive on my Ubuntu 16.04 X86-64 machine builds flawlessly.

I've tried building it on the Tegra with both GCC 6.4 and GCC 5.5 (using update-alternatives) and get the same error.

Once it has failed, it won't build, but gets a different error (can't find pthreads). Running scons -c followed by scons sconsclean doesn't clean things up: the build fails with completely different errors. The only way to "try again" is to delete the entire directory, unzip from the tar file again, then run scons again.

Can anyone offer a theory about what I'm missing?


fyi, I am writing a driver that reads GPS information from a TCP socket instead of a serial port; we already have an INS service running on this machine that manages the serial port and publishes GPS information over TCP to several other applications running on the machine.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]