help-cfengine
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: problem with RSA keys on HP-UX 11


From: Jeff Layton
Subject: Re: problem with RSA keys on HP-UX 11
Date: 31 Jul 2003 20:01:09 -0400

I found a working openssl (though I'm going to have to build one soon,
as the one on the HP porting and archive center's site doesn't link in
libgcc_s as it should).

The problem also wasn't in cfkey, but in the code in crypto.c that reads
in the keys from local files and checks them for validity.

The moral of this story -- it's quite possible to have a 'mostly
working' openssl installation and still find corner cases with problems.

Good luck!
-- Jeff

On Thu, 2003-07-31 at 14:26, Chip Seraphine wrote:
> I had a similar issue with Solaris 2.8/intel.  When I generated keys on 
> another machine (a Linux box) and copied them over, everything was 
> fine.  And as with your case, the same openssl build seemed to make 
> other applications quite happy despite generating invalid keys in cfengine.
> 
> Were you able to compile a 'working' openssl, or did you tweak the cfkey 
> generator, or ... ?
> 
> Jeffrey Layton wrote:
> 
> >After much mucking about, I finally determined that the problem was in the
> >openssl libraries I had installed on this box. They seemed to work fine,
> >but the problem definitely manifested itself in cfengine. In any case, it
> >seems to be resolved now.
> >-- Jeff
> >
> >
> >_______________________________________________
> >Help-cfengine mailing list
> >address@hidden
> >http://mail.gnu.org/mailman/listinfo/help-cfengine
> >  
> >
-- 
Jeff Layton <address@hidden>





reply via email to

[Prev in Thread] Current Thread [Next in Thread]