help-cfengine
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: BerkeleyDB.4.2 Configure Error with 2.0.8p1 and 2.1.1


From: Frank Ranner
Subject: Re: BerkeleyDB.4.2 Configure Error with 2.0.8p1 and 2.1.1
Date: Fri, 30 Jan 2004 00:48:20 +1100
User-agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030624 Netscape/7.1 (ax)

Brian E. Seppanen wrote:

I just installed BerkeleyDB.4.2 on a host I'm trying to install cfengine on and I get the following error when I run configure as follows

./configure --with-berkeleydb=/usr/local/BerkeleyDB.4.2


checking for BerkeleyDB location... /usr/local/BerkeleyDB.4.2
checking Berkeley DB Version... configure: error: This release of cfengine requires BerkeleyDB 3.2 or later

Does anyone know how I can get past this error?

Brian Seppanen
address@hidden
906-475-0107 ext 1040



The answer to your problem has been addressed in another post. When I last built cfengine 2 I added a /var/cfengine/include directory, and symlinked db.h in there. I then ran

./configure --with-berkeleydb=/var/cfengine

which meant that cf* would look in /var/cfengine/lib for the libdb files. This helped with the building of workstations because I preloaded the /var/cfengine tree enough to generate the keys and get the config files after the first boot.

Regards,
Frank Ranner



reply via email to

[Prev in Thread] Current Thread [Next in Thread]