[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [qpimd-users] Installing QPIMD

From: Tom M
Subject: Re: [qpimd-users] Installing QPIMD
Date: Mon, 22 Aug 2011 17:13:47 -0400


I really appreciate your help so far, but I'm still confused...

I tried to start all over and reconfigure everything but I wasn't sure what steps I should do (and shouldn't) and in which order now.

When I started over I did
./configure --prefix=/usr/local/quagga --enable-pimd --localstatedir=/var/run/quagga

and it looked like there were a lot of errors...
and by the time I got to the
when I did sudo /usr/local/quagga/sbin/pimd step the file wasn't even found...

Is there anyway to get a simple step by step instruction on how one might install qpimd from a vanilla start.

I don't understand why they haven't just implemented all of these changes directly into quagga :).


On Thu, Aug 18, 2011 at 4:29 PM, Everton Marques <address@hidden> wrote:
On Thu, Aug 18, 2011 at 5:01 PM, Tom M <address@hidden> wrote:
> I tried the dirty solution first and got this:
> address@hidden:~$ sudo /usr/local/quagga/sbin/zebra -i /tmp/zebra.pid
> [sudo] password for tom:
> 2011/08/18 15:52:26 ZEBRA: Can't bind to unix socket /var/run/zserv.api:
> Permission denied

Ouch. I think the cleanest way to overcome this is by recompiling zebra,
either pointing the state file directory to a more amicable place:
./configure --prefix=/usr/local/quagga --enable-pimd
or instructing zebra to use TCP sockets instead:
./configure --prefix=/usr/local/quagga --enable-pimd --enable-tcp-zebra
Then, make, sudo make install.

The ugly and simple way is to allow anyone to write to /var/run:
sudo chown a+w /var/run.

> 2011/08/18 15:52:26 ZEBRA: zebra can't provide full functionality due to
> above error
> 2011/08/18 15:52:26 ZEBRA: Zebra 0.99.17 starting: address@hidden
> As far as the "proper" solution is concerned. Does this have to do with that
> initial warning:

> state file directory    : /var/run
> config file directory   : /usr/local/quagga/etc
> example directory       : /usr/local/quagga/etc
> user to run as : quagga
> group to run as : quagga
> The above user and group must have read/write access to the state file
> directory and to the config files in the config file directory.

Yes, it is telling you what default user and group are defined in the
daemons, if you don't specify them in the command line.

> ------------------
> Is it possible to get it to work with my current username somehow without
> making a new username and group? I'm not too familiar with linux
> users/groups.

Sure, use something similar to:
mkdir /home/tom/quagga
sudo /usr/local/sbin/pimd -u tom -g tom -i /home/tom/quagga/pimd.pid

> After everything is setup I'm still confused why everything is different
> from the "default" install of quagga as referenced in this
> tutorial: http://openmaniak.com/quagga_tutorial.php

The instructions from that tutorial suppose you are starting from a
precompiled Debian package.

Instructions from qpimd start earlier, by compiling the source code.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]