[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[AUCTeX-devel] GNU emacs: 24.4.1 auctex 11.88: installation problem: sty

From: Uwe Brauer
Subject: [AUCTeX-devel] GNU emacs: 24.4.1 auctex 11.88: installation problem: style files
Date: Sun, 22 Feb 2015 12:41:20 +0100
User-agent: Gnus/5.130006 (Ma Gnus v0.6) Emacs/24.4 (gnu/linux)


I apologize if I miss here something elementary.

Here is what I do:

    -  I unpack auctex-11.88 in ~/emacs/site-lisp/packages/auctex-11.88/

    -  I run ./configure EMACS=/opt/emacs24/bin/emacs
       (nothing more no pkg directory is specified)

    -  I run make

    -  I don't run make install

    -  I add the following paths to my init file
    (setq load-path (cons (expand-file-name 
"~/emacs/site-lisp/packages/auctex-11.88")  load-path))
(setq load-path (cons (expand-file-name
    "~/emacs/site-lisp/packages/auctex-11.88/preview")  load-path))

    -  I add
    (load "auctex.el" nil t t)
    (load "preview-latex.el" nil t t)
    (require 'tex-site)    
    both seems to be equivalent, the latter is the old one from ancient times,
    which I prefer.

    -  now everything seems fine, save as I just found out, the  style
       files. If for example try to use in a beamer file some beamer
       specific command I obtain:

|   Debugger entered--Lisp error: (void-function TeX-arg-beamer-overlay-spec)
|   TeX-arg-beamer-overlay-spec(nil)
|   TeX-parse-argument(nil TeX-arg-beamer-overlay-spec)
|   TeX-parse-arguments((TeX-arg-beamer-overlay-spec 1))
|   TeX-parse-macro("only" (TeX-arg-beamer-overlay-spec 1))
|   TeX-insert-macro("only")
|   call-interactively(TeX-insert-macro nil nil)
|   command-execute(TeX-insert-macro)
   of course I can load beamer.el from the style directory manually and
   everything is fine but this cannot be a general solution.

    -  so I thought of just adding
(setq load-path (cons (expand-file-name 
"~/emacs/site-lisp/packages/auctex-11.88/style")  load-path))
   to my init file, however this turns out to be a very bad idea since
   then on startup I obtain:

| Warning (initialization): An error occurred while loading `/home/oub/.emacs':
| Symbol's function definition is void: TeX-add-style-hook
| To ensure normal operation, you should investigate and remove the
| cause of the error in your initialization file.  Start Emacs with
| the `--debug-init' option to view a complete error backtrace.

   so I am sort of stuck. In Xemacs this does not happen since when I
   compile it as a package or download the package, this load-path issue
   does not occur. I presume elpa would be the equivalent solution but I
   had also problems with elpa.

Could somebody please enlighten me what to do with the files in the
style directory and how to access them.



Uwe Brauer 

Attachment: smime.p7s
Description: S/MIME cryptographic signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]